Yosemite update causes RoboFont not to load

RoboFont Forums Bugs Yosemite update causes RoboFont not to load

This topic contains 7 replies, has 3 voices, and was last updated by  Roberto Arista 2 years, 4 months ago.

Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
    Posts
  • #6031

    Dezcom
    Participant

    Yosemite update causes RoboFont not to load

    Attachments:
    You must be logged in to view attached files.
    #6033

    frederik
    Keymaster

    Hi

    please update to the latest version of RoboFont, it helps :)

    see
    http://doc.robofont.com/download/
    http://doc.robofont.com/version-history/

    thanks

    #6035

    Dezcom
    Participant

    Worked like a charm! ;-) Thanks, Frederik

    #6072

    Roberto Arista
    Participant

    Hi everyone!

    I just bought a new Retina laptop with Yosemite pre-installed.
    I installed Robofont (last version, downloaded today), I am able to launch it, but this is what appears if I ask for a new font (screenshot attached).
    Same problem if I open a .ufo file.

    Script and features windows both seem to work.
    The output window is empty.

    Any idea?
    Is Yosemite still a problem with Robofont?
    I have to consider to downgrade to Mavericks?

    Kind regards

    Attachments:
    You must be logged in to view attached files.
    #6075

    frederik
    Keymaster

    euh, no idea…

    is there a traceback in the output window? or anything listed in the Console.app?
    Never have seen such black smart list and empty font overview.

    could start with removing the preference file “com.typemytype.robofont.plist” in your /Library/Preferences
    and log out or restart

    thanks

    #6080

    Roberto Arista
    Participant

    Due to a hardware problem now my laptop is by the assistance.
    I will follow these advice as soon as I have it back and I will keep you updated.

    Thanks.

    #6094

    Roberto Arista
    Participant

    Hi Frederik,
    a quick follow up about my last problem with Robofont.

    After I picked up my laptop from assistance (the problem was a defective hard drive) I had to reinstall OSX and all the softwares.
    Robofont started to work properly again, so I thought this errors was caused by the hard drive damaged sector or something similar.

    But then, after a while I came back working on creating some smart sets via Python, that actually was exactly the last job I did with Robofont before this error reported here.
    I probably created too much smarts sets and blocked the whole application. After cleaning the preference file, Robofont started again to work.

    Here it is an example of what I was doing (creating smart sets according to some txt files with glyphs name inside):
    https://gist.github.com/roberto-arista/a3b3d286ecb2cd308529

    The documentation about smart sets management through python is super synthetic, so I have some questions:
    – where can I find a list of the possible queries? (eg: ‘Less then five contours’)
    – are there limits I should take into consideration?
    – are there case studies (in external plugin too) that I could study?
    – is it possible to group smart sets in smart groups via Python?

    Thanks!

    #6116

    Roberto Arista
    Participant

    Hi Frederik!
    Could you link a reference concerning queries for smart sets via Python?

    Thanks

Viewing 8 posts - 1 through 8 (of 8 total)

You must be logged in to reply to this topic.