Not able to open glyphs in glyph edit window

RoboFont Forums Troubleshooting Not able to open glyphs in glyph edit window

This topic contains 4 replies, has 3 voices, and was last updated by  Anonymous 1 year, 1 month ago.

Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
    Posts
  • #6267

    Anonymous

    Hello,
    I’m trying to solve this issue. Glyph editor window doesn’t pop up when I want to edit particular glyph. It doesn’t work even I tried to save it as the new font or export it as the new ufo file from different softwares. But the thing is – glyph edit window works in other softwares.
    I attached probably damaged ufo files.
    Thanks,
    Filip.

    #6270

    frederik
    Keymaster

    Hi Filip

    do you know which glyph is not opening?

    I would also try to launch RoboFont with shift down, RoboFont will not install any extensions, and check if this issue is still there.

    thanks

    #6271

    Anonymous

    Hi Federik,
    thank you for the quick respond. I tried it with shift down in “Safe Mode” you call it. But issue still there.
    The problem is for all glyphs. It seems for whole encoding. I tried also add new glyphs. It doesn’t work for it as well.

    #6272

    Jens K.
    Participant

    It seems the problem is that some of your layers are called 1, 2, 3. RoboFont doesn’t seem to like that. In the console, there’s this message:

    RoboFont[14862]: -[OC_PythonNumber isEqualToString:]: unrecognized selector sent to instance 0x7fad4ce63150

    Rename your layers in the inspector window, and the glyph window will open again.

    #6273

    Anonymous

    Brilliant,
    it works now! You have my thanks!
    Filip.

Viewing 5 posts - 1 through 5 (of 5 total)

You must be logged in to reply to this topic.